Free network scanner

Free download
Current version: 2.4.2601
License: Freeware


Advanced IP Scanner - Help

Advanced IP Scanner is fast and free software for network scanning. It will allow you to quickly detect all network computers and obtain access to them. With a single click, you can turn a remote PC on and off, connect to it via Radmin, and much more.

Everything you need to know about Advanced IP Scanner in just 3 minutes (video)

Network Scanning and Retrieving IP and MAC-addresses

Using Advanced IP Scanner

Network Scanning

1. Enter your range of IP addresses (“IP” button in the toolbar will help you to set the IP-address range of your network).

2. Click "Scan". Once the scanning process has been completed you will get a list of the computers in the network.

Creating a Favorites List of Computers for Regular Use

1. Scan the network.

2. Select the required computers and click the "Add to "Favorites" option in the shortcut menu.

3. You can now work on these computers by using the "Favorites" tab.

4. You can also add a new computer to "Favorites" by selecting "Actions -> Add computer…" in the menu and entering your computer's information in the dialog box.

You can also save the list of computers from the "Favorites" tab. The file will be saved in .xml, .html, .csv formats.

To perform this operation:

  • Shortcut menu - "Save selected";
  • Main menu - "File -> Save as…".

To load a list of computers from a file to "Favorites", follow these steps: from the main menu choose "File -> Load favorites…"

Radmin and Advanced IP Scanner

Radmin is one of the best remote control software for Windows, allowing you to work at a remote computer as if you were sitting right in front of it, using a standard graphical interface.

1. Select the required computer from the results of the network scan or from the "Favorites" tab.

2. If Radmin Server is found on the computer, you can connect to it by selecting the corresponding type of Radmin connection in the shortcut menu. To connect to a remote computer, you need to install Radmin Viewer. You can download it for free at: www.radmin.com/download/.

You can also use the portable version of Radmin Viewer. Enable "Use portable version of Radmin Viewer" in "Settings -> Options… -> Misc" and specify the path to it.

Functions

Save List

This function allows you to save the list of computers from the current tab. The file is saved in .xml, .html, .csv formats.

To perform this operation:

  • Shortcut menu - "Save selection";
  • Main menu - "File -> Save as…".

Load List

This function allows you to load the list of computers from the specified file into the "Favorites" list. Only .xml files can be used for loading.

To perform this operation:

  • Main menu - "File -> Load Favorites".

Toolbar –Class "C" Subnetwork

This allows you to set the starting IP-address as ***.***.***.0 and the end IP-address as ***.***.***.255, where "***" are the current values of the entered IP-address.

To perform this operation:

  • Toolbar - "class "C" subnetwork" button.

Toolbar – Current Computer Subnetwork

This function allows you to set the starting and ending IP-addresses as per the subnetwork mask of your computer.

To perform this operation:

  • Toolbar - "IP" button.

Tools – Ping

Starts a terminal window with the ping command to a remote computer.

To perform this operation:

  • Shortcut menu - "Tools -> Ping".
  • Main menu - "Actions -> Tools -> Ping".

Tools – Tracert

Starts a terminal window with the tracert command to trace the route to the remote computer.

To perform this operation:

  • Shortcut menu - "Tools -> Tracert".
  • Main menu - "Actions -> Tools -> Tracert".

Tools – Telnet

Starts a terminal connected to a selected computer on the standard Telnet port.

To use the telnet client (other than default client) you need to create a path to it in "Settings -> Options… -> Misc".

To perform this operation:

  • Shortcut menu - "Tools -> Telnet".
  • Main menu - "Actions -> Tools -> Telnet".

Tools – SSH

Allows you to connect to the selected computer via SSH-Clent selected by the user. SSH-client is specified in the "Settings -> Options ...->Misc"

To perform this operation:

  • Shortcut menu - "Tools -> SSH".
  • Main menu - "Actions -> Tools -> SSH".

Options - Performance

The "High-accuracy scanning (lower speed)" option allows you to scan each computer several times. This improves the accuracy of the scan, but takes more time.

The scanning rate slider allows you to smoothly change the speed of the scan, as well as the processor and network load.

Click on the "OK" button to save changes to the settings.

To perform this operation:

  • Main menu - "Settings -> Options… -> Performance".

Options - Resources

The Resources section allows you to select the resources to be scanned. The smaller the number of resources selected, the less time the scanning process will take.

Click on the "OK" button to save changes to the settings.

To perform this operation:

  • Main menu - "Settings -> Options… -> Resources".

Options – Misc

The Misc settings section of the program allows you to enable automatic checks for updates, and specify the use of SSH client, Telnet client, FTP client, HTTP client. You can also enable the use of the portable version of Radmin Viewer and specify the path to it.

In this section, you can enable the table colors’ alternation.

To perform this operation:

  • Main menu - "Settings -> Options… -> Misc".

Shut Down Computer

This function allows you to try shutting down the selected computer remotely (if you are authorized to do so).

To perform this operation:

  • Main menu - "Actions -> Shut down";
  • Toolbar - "Shut down" button;
  • Shortcut menu - "Shut down";
  • Toolbar - "Shut down" button (additional buttons can be added to the toolbar from the main menu under "View" section).

After pressing the "Shut down" button, the dialog box shown below will appear on the screen, where the following operations can be carried out by selecting the corresponding options:

  • "Forced shutdown" – shut down/reload the computer, even if some programs are still running and warning messages about the possible loss of unsaved data in case of restart appear;
  • "Reboot" – reboot the computer instead of turning off;
  • "Message" – warns the user that "Your computer will restart in N seconds".

Aborting Remote Shut Down

This function allows you to cancel the remote shut down of selected computers.

To perform this operation:

  • Main menu - "Actions -> Abort shut down";
  • Shortcut menu - "Abort shut down";
  • Toolbar - "Abort shut down" button (additional buttons can be added to the toolbar from the main menu under "View" section).

Wake-On-LAN

This function sends the "Wake-On-LAN" command to selected computers. This command will only be sent to computers where the MAC-addresses have been identified.

To perform this operation:

  • Main menu - "Actions -> Wake-On-LAN";
  • Toolbar - "Wake-On-LAN" button;
  • Shortcut menu - "Wake-On-LAN";
  • Toolbar - "Wake-On-LAN" button (additional buttons can be added to the toolbar from the main menu under "View" section).

Browse Computer

This function will open Windows Explorer showing the selected computer.

To perform this operation:

  • Main menu - "Actions -> Explore";
  • Shortcut menu - "Explore";
  • Toolbar - "Explore" button (additional buttons can be added to the toolbar from the main menu under "View" section).

HTTP Connection

Allows you to connect to the computer via HTTP protocol using a browser selected by the user. HTTP client is specified in "Settings -> Options… -> Misc". If the HTTP client is not specified, the default client is used.

To perform this operation:

  • Main menu - "Actions -> HTTP";
  • List of computers - double click on the computer icon, double click "HTTP" for connection;
  • Toolbar - HTTP button (additional buttons can be added to the toolbar from the main menu under "View" section).

HTTPS Connection

Allows you to connect to the computer via HTTPS protocol using a browser selected by the user. The same client is used to connect to the HTTP protocol.

To perform this operation:

  • Main menu - "Actions -> HTTPS";
  • List of computers - double click on the computer icon, double click "HTTPS" for connection.
  • Toolbar - HTTPS button (additional buttons can be added to the toolbar from the main menu under "View" section).

FTP Connection

This function allows you to connect to the selected computer via FTP protocol using a browser. You can specify a different FTP client under "Settings -> Options… -> Misc" section.

To perform this operation:

  • Main menu - "Actions -> FTP";
  • List of computers - double click on the computer icon, double click "FTP" for connection;
  • Toolbar - FTP button (additional buttons can be added to the toolbar from the main menu under "View" section).

Connection Via Radmin

This function starts Radmin to connect to the selected computer.

To perform this operation:

  • Main menu - "Actions -> Radmin";
  • Shortcut menu - "Radmin";
  • List of computers - double click on the computer icon, double click "Radmin";
  • Toolbar - you can add buttons to your toolbar in the main menu under "View" section.

Remote Desktop Protocol Connection

RDP (Remote Desktop Protocol) – is an Application-level protocol Microsoft, used to provide the user with a remote server that is running Terminal Services Connections.

Allows you to connect to a selected computer via RDP.

To perform this operation:

  • Main menu - "Actions -> RDP";
  • Shortcut menu - "RDP";
  • List of computers - double click on the computer icon, double click "RDP";
  • Toolbar - RDP button (you can add buttons to your toolbar in the main menu under "View" section).
Copyright © 1999-2015 Famatech. All rights reserved.